백인감자

파이썬 2.7 , 3.x 버전 함께 사용 & OpenCV 환경구축 본문

OpenCV

파이썬 2.7 , 3.x 버전 함께 사용 & OpenCV 환경구축

백인감자 2017. 7. 20. 17:08

파이썬 2.7 버전

openCV 를 다운받고 압축을 푼 후 /opencv/build/python 에 들어가서 본인의 환경(32/64 bit) 에 맞는 폴더에 들어가서

cv2.pyd 파일을 복사 후 C:\Python27\Lib\site-packages 폴더 내에 붙여넣기 해주면 된다.



파이썬 3.x 버전 (3.6 이라 가정하고 설명)

http://www.lfd.uci.edu/~gohlke/pythonlibs/#opencv  에 들어가서 본인의 환경에 맞는 whl 파일을 다운받는다.



cmd 에서 whl 파일이 설치된 경로로 이동 후 명령어를 통해 whl 파일을 설치한다.





위의 두 버전을 동시에 사용하려면 환경 변수에서 Path 설정에서 설치경로\Python27 , 설치경로\Python27/Scripts

설치경로\Python36 , 설치경로\Python36/Scripts   총 4개가 있는데 이 4개로 적혀있는 경우 파이썬을 실행하면

2.7 버전이 우선실행되어서 3.6 버전이 실행이 안된다고 해서 미완이다.

0 Comments
댓글쓰기 폼